Installing the quadric SDK

The component specs herein should be used as a baseline. Contact quadric support for help sizing a host platform to serve your performance goals.

Note

Please contact sales@quadric.io to procure the SDK or to order a quadric Development Platform or Devkit.

Hardware Requirements

We recommend a laptop, workstation or virtual machine with the following specs:

Minimum

Recommended

OS

Linux, MacOS, Windows

Linux

CPU

2 Core

4 core+

RAM

16GB

16GB+

Drive type

SATA Hard drive

SSD

Drive size

30GB available

30GB available+

Software Requirements (Docker)

The only software requirement required for the quadric SDK is Docker. You can install Docker by clicking the link below:

  1. Click here to get Docker.

  2. Alternatively, install docker via cli as shown below.

$ curl https://get.docker.com | sh

Installing or Upgrading the quadric SDK

The quadric SDK is usually distributed to clients via tarballs (*.tar.gz). To install or upgrade the SDK, follow the steps below:

  1. Unzip the provided tarball

$ tar -xvf graphsim*.tar.gz
  1. Load the SDK image provided

$ docker load -i docker/*.tar
Loaded image: quadric.io/graphsim:0.8.8
  1. This completes the installation or upgrade of any SDK release.